Jump to content

TRevver

Members
  • Posts

    51
  • Joined

  • Last visited

Profile Information

  • Location
    Winslow
  • Cars Owned
    1967 Vitesse 2L MK1 convertible. Royal Blue and White.

Recent Profile Visitors

74 profile views

TRevver's Achievements

Newbie

Newbie (1/13)

2

Reputation

  1. TRevver

    Engine mount

    I always thought Triumph engines left the factory painted black. Some say it was so you couldn’t see the oil leaks!
  2. TRevver

    Engine mount

    Thanks, I see the benefit of more room between the fan and radiator but I think I'll stick with plan A. Whilst I'm on, I take it the main reason the bolts attaching the bell housing to the engine backplate go in from the front (nut attached on the gearbox side) is to keep the threads clean? Except for the 3 studs at the top which can only go in from gearbox side.
  3. TRevver

    Engine mount

    Inserted the engine block this morning and not entirely convinced the engine mounts are correctly located. Does the vertical metal section of the rubber block bolt inside the section attached to the front suspension turret or outside? At the moment, they are bolted outside (forwards of) the turret section but not convinced it looks right.
  4. It was me that resurrected it today - looking to see if anyone else had solved the same problem I had. Bob should get royalties!
  5. Thanks Paul, I did have a theory that the first of the 2L engines had a lot of the 1600 bits from the parts bin - makes sense.
  6. I'll leave it in the dismantling fluid overnight, if that doesn't work with some heat, I'll get the hacksaw to it as you suggest (before accidentally rounding off the corners with brute force!) Thanks
  7. Thanks for the info. I thought as much. It's been soaking in plus gas all afternoon. It'll still be there tomorrow and if reluctant to separate, I'll apply some heat.
  8. Got a similar issue. Vitesse 2L MK1. Ordered a new oil pressure switch from Canley but the thread seems different to the old one which is removed with the adapter. Not entirely sure if the new switch is supposed to go straight in the block? as shown for Vitesse 2L MK1 AND GT6 MK1 . in which case how does it seal? It feels like the thread is too loose but may be tapered? the Canley parts diagram doesn't show a washer and the part number is the same for the switch either with or without an adapter (GPS117). Or does it need to go into the adapter - which creates a new problem as the old switch is well and truly attached to the adapter and the adapter appears to be no longer available (tried Mick Dolphin). To further confuse me, only the Vitesse 1600 page on the Canley site shows the switch with an adapter but the 2L (MK1 and 2) don't - neither does the GT6. https://www.canleyclassics.com/?catalogue=triumph-vitesse&diagram=triumph-vitesse-1600-engine https://www.canleyclassics.com/?diagram=triumph-vitesse-mki-2-litre-engine-manifolds-and-carburettors Any suggestions gratefully received! (GPS 117 on the top, old setup underneath)
  9. I just spoke to the guy at EP Services. Very helpful chap called Paul King (07770 747724). He's happy to make a pump up out of spares with ceramic bearings etc, guaranteed for life for about £60 without an exchange unit, if anyone else is interested. He's grateful for any business coming through the forum. I put him in touch with the guy selling the job lot on eBay too.
  10. Mine is definitely the newer (sealed unit) pump. I might give EP Services a call anyway, they might have some old pumps knocking about - there phone number is on the site, otherwise I'll get another one of the camel / roadkill seal variety. I saw the bay ad on eBay for the job lot of 60 but I don't have enough room to hide the other 59 from the other half! Wonder if the club would be interested in buying them?
  11. I spent some lockdown time refurbing the radiator from my MK1 Vitesse. It looked great - for a while! The car didn't run much last year (that's a different story) but I noticed a pattern of "rusty marks" over the engine-facing side. At first I though this was coolant that had maybe escaped from the weep hole on the pump (manufacturers mark is "County"), and then found it's way along the taper and out of the 4 openings at the front of the pump. However, it appears to be where the radiator paint has chipped / flaked off (Eastwood black radiator paint https://www.frost.co.uk/eastwood-radiator-satin-black-aerosol-340g/?ph=782f5d1b5f6507f8e0765137&gclid=EAIaIQobChMItt3Vma2e7wIV-IFQBh0ayAjVEAAYASAAEgIL5fD_BwE). Anyone had any similar experiences or got any ideas what has caused it? Also, the pump was a bit noisy and appeared to be suffering from worn bearings - it was often quite "squeaky" in operation. I've cleaned up the crud from the impeller but am thinking it could be due for replacement. I've seen the posts that they don't last long anyway. Are they all pretty much the same in terms of quality? A N.O.S or refurbed unit would seem a good alternative as it seems they were built to last but can't see any advertised, tried flea bay, Mick Dolphin etc.
  12. The vent on the Rocker cover is completely clear, no wire wool. I think it was just due to seepage around the top of the pushrod sleeves over time. Pete, the block is stripped back of ancillaries and it's booked in for cylinder hone/bore, piston rings, main bearings, etc. May as well get it all done whilst it's in bits, she deserves it! Hopefully over the next few weeks. I'll keep you posted...
  13. The home made tool seemed to work well with 2 x 3/8 flared sockets (7/16 seems to also fit well). The other ingredients I used were a 110mm M8 high tensile nut and bolt with 2 M8 penny washers. The push rod sleeves certainly now look like a better fit. I put a bead of the loctite 290 on both ends as well just to be sure.Thanks for the suggestions.
  14. I was going to skip the baking today and make a ploughman’s instead, but we’ve run out of pickled trunnions.
  15. Thanks for the passing on the results, I made an exhaust clamp casserole not long ago. Could we have a challenger to The Great British Bake Off?
×
×
  • Create New...