Jump to content

Search the Community

Showing results for tags '1600'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 2 results

  1. hello How well does 2L gearbox parts work in a 1600 MK1 gearbox. What would be the main differences. Will syncro mesh and roller bearing(s) interact? regards Flemming
  2. Out of the blue my vitesse 1600 lost power and stopped. Had one start with full choker on hot engine. Very high revs and a supecious synthetic smell. Ignition okay, compression okay, fuel okay. Have to had it towed to my garage. It was raining and dusk had settled on. Suspected the diaghrams and when I lifted the top of the carbs the front one was jamed. I.e, I had to use a soft hammer to get i loose and had to use substantial force to pull it of. The piston and needle was jamed. I replaced the piston, centralized and all, and have the piston to run alright. Enhine wont start, no fuel through front carb - at least three dry front plugs , compared to vissible wet three rear plugs. I checked both floath and replaced the needle valves. I blew air through visible holes, cleaned up and reassembled and fitted. Still no fuel to the front three cylinders - dessert dry plugs. When I blew air into tthe carb it pull up fuel fron the float chamber al right, meaning no cludging here. How can the carb get in a state like this? Fire? How come there's no fuel passing through the carb? Will a sufficient big leak in the inlet manifold take all suction power out of the carb?(I did saw some unusual smokw when the engine was running for a few seconds full choked and with very high revs.) Any comments most welcome. Thansk, Flemming
×
×
  • Create New...