Jump to content

Search the Community

Showing results for tags 'Clutch'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 7 results

  1. Hi Everyone. In response to the tremendous amount of help that I have received from the forum members over the past few weeks, I have decided to open a new thread to keep all my woes together. I hope that some of my problems will help other members as I try to put my Spitfire back on the road after being mothballed for over 20 years. The topics already covers elsewhere are faulty tail/brake lights, ceased clutch, refurbishment of the horns, strange symbols in wiring diagrams, carburetor cleaning and setting, and other stuff which I will edit in as it comes back to mind. I have also converted my original pump windscreen washer unit to electric and will post details of this is due course for anyone interested. My thanks go to (in no particular order) dougbgt6, pete lewis, casper, colin lindsay, bordfunker and everyone else who has contributed to my woes and offered so much help. Some items covered in this thread which may be of interest to others - Page numbers may change slightly as this index gets longer - Page numbers will be added as I find them along with other items. Adhesive Bonding - Pages 35-41 Blade Fuse Box - Page 32 Differential Front Oil Seal - Page 2 'Dustless' Sanding Device -- Page 42 Exhaust Supply & Fitting - Page 1 Fuel Pipe Gates Barricade - Page 49 Gutter, windscreen - Page 21 Hard Top Reconstruction - Page 42, 49 Heater Control Illumination - Page 39 Heater and plumbing - Page 9 Leaf Spring Garage Fitting Disaster - 24, 28 Bonnet Refurbishment - Page 41 onwards Pets - Page 43 Plumbing and Heating -Page 9 Radio (cheap oriental) - Page 37+ 39 plus others Sparkrite SX4000 (Electronic Ignition) - Page 32 Water Pump (Spitfire/Herald) - Page 1 Windscreen gutter - Page 21 Trunnions, Front, Cleaning Out - Page 1
  2. Help! After putting My Vitesse mkII on ramps to check the diff it has now developed a clutch issue? Driving off ok, but change to 2nd and the clutch is making a fairly loud rattle when coming off the clutch pedal that keeps going until I accelerate Closer inspection reveals the slave piston is 'wobbly' as is the plate attached to the gearbox drive shaft. There is also lots of movement in the clutch pedal before it starts to feel pressure. Is it the spring inside the piston assembly or something worse?? Is it ok to keep driving short distances also?
  3. Hi all My 1500 spit (76) won't go into gear. It was fine, then started crunching into some gears now impossible to engage unless the engine isn't running. Actual engagement is very low on the pedal. No fluid leaks. Bled clutch. Was fine for a bit then started doing exacrly the same. I was about to change the slave but do you think it could be the master? Any advice appreciated. Many thanks Rich
  4. Helloo. Does anybody have any experience of using XRN Engineering parts over Borg & Beck please (which are twice the price) in terms of quality / long lasting. Changing the Clutch Slave Cylinder (spit 1500). Apologies - couldn't find the correct forum for clutch matters. Many thanks for any advice, much appreciated. Rich
  5. I've changed the clutch on my Vit6 but am having problems with clutch drag. I can't engage first when the engine is running. If I engage first and then start the engine the car doesn't creep forward. When I depress the clutch pedal it doesn't touch the floor but the throw-out arm does touch the bell-housing which suggests that the throw-out arm is bent (unlikely). I did inspect it when I stripped it down and it looked as new but there again I didn't have anything to compare it with. I didn't have this problem with the previous clutch. It's a NOS coil spring clutch cover and friction plate. Has anyone got any suggestions as to what the problem is please?
  6. Hi guys, My triumph GT6 Mk3 is driving now after a full restoration and when I start the engine and put the car into 1st gear there is nothing a miss, but when I release the clutch there is an odd noise like a faint squeal of a tyre and it seems to be coming from the slave clutch cylinder attached to the bell housing.. Can someone explain this to me? It's quiet and once the gearbox tunnel Is in I wouldn't be able to hear it. But was just worried slightly and would love to know what you guys think? Doesn't sound mechanical to me.. Can send a video if required. Thanks! Jim.
  7. I need a 6.5 inch diameter, 20 spline clutch plate for my spitfire. everywhere does 10 spline 6.5" or 20 spline 7 1/4 but not the 20 spline 6.5 any suggestions please??? many thanks
×
×
  • Create New...