Jump to content

Search the Community

Showing results for tags 'heater'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 9 results

  1. Ayup folks. I’m rebuilding the dashboard of my ‘72 GT6 and I’m at the heater controls. They’re due a deep-clean (topical) with some brake cleaner and a light lube. What lube have you used at the slides and pivots? PS: Who knew that the screen demist ducts and the wiper tube battle for the same space?
  2. Hello, The moveable air flow directors on my heater outputs into the footwell are seized. The face louvres are fine. Does anyone know of a technique to free them up? Can I just squirt in some lubricant? thanks.
  3. My car seems to demist the passenger side of my windscreen at least twice as quick as the drivers side if not faster and I was wondering if anyone else has this same issue? I've checked all the hoses and all are sealed with no splits, my heater flaps are adjusted evenly and still I have superior airflow from the passenger side to the point where I've considered longer pipes and swapping them over (if there's space to do so) The only cause I can think of is the fact that the passenger side outlet from the heater box is higher up than the driver side
  4. Well contrary to popular belief, not all Gt6 drivers wear shorts. Having ‘dynamatted’ my mk1 over the winter it would appear that my heater doesn’t work. I took my car today, but had to return to get my woolly hat, gloves and an extra fleece! My question is how easy are they to take out with the interior in? Or what’s the minimum I have to take out to get access? Thanks hag
  5. I'm sure we've all been there - repaired or replaced the broken / faulty bit on our Triumphs only to find it doesn't cure the problem we were seeking to solve. Well, the heater on my GT6 packed up earlier this year - clearly there was no flow through the matrix and it needed a flush (diagnosis based on the water in both the flow and return pipes warming close to the engine, but no evidence of flow). Rather irritating, as having properly sealed the tunnel and stopped up the holes in the bulkhead, the car has actually been cold inside over the recent weeks! Anyway, I bought the car a new set of spark plugs for Christmas as it's been running a little bit rough and fitted them this afternoon. Slight rough running is still there, but the heater's now working again! ? On the rough running, I did find the car pulling in air through the small vent hole on top of the crankcase pressure control valve due to a holed diaphragm - new one on order, so fingers crossed that doesn't stop the heater working again... HNY, Gully
  6. Hi, My MK3 heater doesn't seem to match the picture in the parts manual and the dimensions of the MK1,2,3 matrix I've been quoted is too small. The box still has the little flaps for foot-well warmth, but it's wider and has "protective ears" for the flaps. As you can see from the picture the matrix fits across the baffles tightly - the Mk4 matrix is just too narrow at this point to fit! Has someone at some point fitted the wrong heater matrix or am I going to need to modify my MK3 heater box to fit a MK4 matrix? It will fit I think at a push! Anybody come across a heater like this? David
  7. Hi guys, I am struggling a lot with the heater pipes to the fans on my GT6 MK3 at the moment. I cannot figure out the layout of them. I have looked at the general arrangement drawings of them and it confuses me more. I have got the pipes in place, but not sure how the parcel tray/glovebox would fit. I have attached pictures of my arranging of the pipes. Also after looking at triumph GT6's online I couldn't see fans attached to the parcel trays are they bolted underneath the parcel tray? Any help in this matter would be greatly appreciated! Kind regards, Jim.
  8. Hi guys, I have been trying to figure out the heater unit pipes (that go to the fans in dash etc) locations for a couple days now and can't seem to figure them out and in which order?? I have attached pictures of both set of pipes and all I want to know is which one goes on which side? And also there is a mounting on one of them where does that mount to? Glovebox mounting? Please see pictures below. If anyone can give me some guidance or even better photos of their layout I would greatly appreciate it. Kind regards, Jim.
  9. Two parts to this question: (1) I've just had some wiring fixed around the Kenlowe electric fan (on my 1977 Spitfire 1500) and I'm wondering if the electrician has set it up to kick in early enough - the temp guage now shows just over three quarters before the fan kicks in. It then runs until the guage shows just below three quarters. It used to kick in just above half way on the guage and that was good for peace of mind. But maybe it's fine for the engine temperature to sit at around three quarters? (2) When I was in traffic yesterday I tried to dissapate a bit of heat by opening up the heater in cabin, but then I realised I don't REALLY know how the heater works - for the left knob the labels from left to right are "CAR DEFROST FULL MAX OFF" "Defrost" and "Off" are pretty obvious, but the others are more ambiguous! Can anyone elighten me?? (The other knob on the right is obviously just a temperature slider!). Cheers!
×
×
  • Create New...