Jump to content

Search the Community

Showing results for tags 'rattle'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.

Product Groups

  • Widgets

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 2 results

  1. Help! After putting My Vitesse mkII on ramps to check the diff it has now developed a clutch issue? Driving off ok, but change to 2nd and the clutch is making a fairly loud rattle when coming off the clutch pedal that keeps going until I accelerate Closer inspection reveals the slave piston is 'wobbly' as is the plate attached to the gearbox drive shaft. There is also lots of movement in the clutch pedal before it starts to feel pressure. Is it the spring inside the piston assembly or something worse?? Is it ok to keep driving short distances also?
  2. Hi all, Adamant on becoming a classic car driver / enthusiast and found a nice 50year old triumph 1300 FWD within budget. Been to view it, needs a bit of TLC cosmetically but undergone a decent amount of mechanical works and it's just passed an MOT no advisories. My only real concern is the way the engine sounded, there was quite an obvious clattering sound which grew as the car accelerated. I'd be grateful if you could see the attached video and give me any idea of if I should be concerned as a first time buyer of a classic about this kinda noise. Is it normal or a serious underlying condition? https://www.youtube.com/watch?v=KqOQTXzJW2o&feature=youtu.be My only other concern was looking up into the engine bay from under the car, there was some oil present on the front of the engine, I was with the guy with several hours though and none ever dripped down to the floor, so uncertain if this is an old issue. Appreciate its not the best angled photo but the best I could do I'm very appreciative of any help and hopefully in the next few days I might have myself a cracking piece of history and become an active member of the forum (y) Regards -Si
×
×
  • Create New...