Jump to content

Search the Community

Showing results for tags 'speedo'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 6 results

  1. Anyone else had issues with a new speedo cable for GT6 mk3 with overdrive? Please see attached picture, the black one is the new one. The end fittings are wrong: too small at the od 90 degree drive and too big at the rear of the speedo.
  2. Hi, I'm looking for recommendations for anyone who can re-calibrate the speedo in my Mk2 Spitfire please. It seems to work fine but is registering a much lower speed than I'm actually doing! Thanks Kevin
  3. Need help, Spitfire mkIV the speed was playing up, reading below the speed and distance it should, the engine has been changed to a 1500, but still has the original gearbox (I think). I’ve had the car resprayed, but somehow they seem to have blown all the gauges and radio. I had brought some second hand gauges so replaced them easily. The originals were jaegar which I’m planning to get refurbished, the speedo is now seized. So the new gauges are smiths, when I connect the speedo I get no reading at all, I checked everything was ok at the speedo end, which it was, I managed to get the gearbox end off ok but the thread is stripped on the gearbox so I don’t think it was engaging properly. Is this easy to change on the car with the gear box tunnel removed? And is it ok to drive the car with nothing plugged into the gearbox? (I have a gps speedo). Thanks
  4. Hi guys, I just wanted some clarification as to what this cable does off a Triumph GT6 MK3 and where it goes, I labeled one end 'speedo' when I took it off the car 2 years ago when I started the full restoration. But I don't know where the other end goes to? Pics below. Regards, Jim.
  5. Hi everyone, So i have recently changed out the speedo cable and angle drive running off my overdrive as the previous one was incorrect and snapped inside the pin, thankfully i was able to remove the snapped pice and install a new angle drive (from rimmer bros) i installed it exactly as instructed to do so with the washer, i got to about 80miles and the it is broken again, i haven't check but I'm assuming its in the same place, the cable is snapping inside the pin coming from the overdrive, has anyone else experienced this? i figure it could be one of 3 issues 1. Speedo cable has a kink in it (it does not) 2. There is an issue with the pin in the overdrive unit. 3. The speedo is jamming stopping the cable and making it snap in the right angle drive any help would be much appreciated, as this is driving me nuts haha. thanks
  6. The speedometer on my Mk3 GT6 has stopped working. I haven't started looking properly yet but can anyone advise - - what's the best way to get at the speedometer? It's really tight behind it to try and get at the retaining screws or speedo connection. Can I get at the back of it by removing the centre panel on the dashboard? - can I get at the gearbox speedometer drive connection from inside the car by removing the gearbox cover? - finally, if I can get to both ends of the cable and it needs replacing is it straight forward from there on? Any help much appreciated.
×
×
  • Create New...