Jump to content

Search the Community

Showing results for tags 'stromberg'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Admin
    • Forum Announcements
    • Forum Help and Suggestions
  • Technical
    • Engine
    • Cooling System
    • Gearbox & Overdrive
    • Drivetrain & Rear Axle
    • Electrical System
    • Bodywork & Fittings
    • Chassis, Suspension & Steering
    • Braking System
    • Fuel System
    • General
    • Tools
    • Parts Wanted
    • Interchangeable Parts
  • Me and My Cars
    • I thought I'd introduce myself
    • My car's history
    • My Triumph Restoration Project
    • My NON-Triumph cars
  • Members Chat
    • Meetings
    • International
    • Club Events
    • Other Events
    • Lounge Bar
    • Stolen
    • Spotted
    • Out and About in my car
    • Area 51
  • Downloads
    • 2021 Shop Catalogue
    • Technical Directory & Car Model Specs
  • Club Shop
    • Club Shop

Blogs

  • John Bonnett's Blog
  • Cookie's Blog
  • Kev Makin's Blog
  • andyblam's Blog
  • russ' Blog
  • Garry's Blog
  • DGC's Blog
  • JonseLucker's Blog
  • CJL1281's Blog
  • Robinson's Blog
  • Robinson's Blog
  • theestimator's Blog
  • buell's Blog
  • kasey's Blog
  • Stuart R's Blog
  • Nmuntzer's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • Brian witherington's Blog
  • 69mk3's Blog
  • Yakooza2's Blog
  • vitessesteve
  • Brian Sculpher

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned


TSSC Membership Number


Cars Owned

Found 6 results

  1. Hi. I have a Mk II GT6 that has been off the road for about 10 years, and am looking to get it back there for its 50th birthday (September). My issue at the moment is that the engine is running very rough (misfires and very little power). I'm gradually working my way through potential causes (timing, valve clearances, etc) but my suspicion is that the problem is with the carbs, and one thing I want to check is the needles. The issue is complicated by the fact that the previous owner had some modifications done, the relevant ones here being that the engine is stroked out to 2.5 litres and has a Moss fast road cam. There was also fuel injection fitted, but I had that changed back to carbs (Stromberg 150 CD). My questions are (1) does anyone know what the correct needles would be for this setup, and (2) if the current needles were incorrect, would that alone be sufficient to cause the problems I am experiencing? Thanks
  2. Hi everyone, I seem to be replacing rubber ‘o’ Rings from the brass adjustable jet on the bottom of a stromberg on a regular basis, as they just keep leaking. I have a couple of spare carbs and have checked them all and the adjustable jet seems too loose in the brass jet holder and moves around a bit in all of them, is this normal? I’m assuming these things can’t really wear as the tolerance is in the ‘O’ ring. It’s not leaking from the brass jet holder/ float chamber housing ( the big O ring) always on the adjustable jet. Any ideas how to stop it leaking? I’ve looked at all the usual suppliers but can’t find replacement jet holders, Can you buy new ones somewhere? Thanks as always. Hag
  3. Can anyone let me know what the adjusting screw in the highlighted area is for?
  4. Out of the blue my vitesse 1600 lost power and stopped. Had one start with full choker on hot engine. Very high revs and a supecious synthetic smell. Ignition okay, compression okay, fuel okay. Have to had it towed to my garage. It was raining and dusk had settled on. Suspected the diaghrams and when I lifted the top of the carbs the front one was jamed. I.e, I had to use a soft hammer to get i loose and had to use substantial force to pull it of. The piston and needle was jamed. I replaced the piston, centralized and all, and have the piston to run alright. Enhine wont start, no fuel through front carb - at least three dry front plugs , compared to vissible wet three rear plugs. I checked both floath and replaced the needle valves. I blew air through visible holes, cleaned up and reassembled and fitted. Still no fuel to the front three cylinders - dessert dry plugs. When I blew air into tthe carb it pull up fuel fron the float chamber al right, meaning no cludging here. How can the carb get in a state like this? Fire? How come there's no fuel passing through the carb? Will a sufficient big leak in the inlet manifold take all suction power out of the carb?(I did saw some unusual smokw when the engine was running for a few seconds full choked and with very high revs.) Any comments most welcome. Thansk, Flemming
  5. Can someone please tell me what the red arrow in the attached picture is pointing to. I would like to replace it, but don't know what it's called and haven't been able to find anything that might describe it in a parts diagram. Thanks Bill Owen '73 Triumph GT6
  6. I'm looking at possible carb upgrades for my Mk3 GT6. Having been put off the idea of fitting Weber carbs, I'm looking at triple Strombergs. Can anyone on here advise as to whether it's a good or bad idea, have they done a similar conversion etc? Any mod would have to be a simple 'bolt on' as I want the option to return to stock in the future. Thanks in advance
×
×
  • Create New...