Jump to content

HS2 Carburettor Flooding


rbalding
 Share

Recommended Posts

I have just completely rebuilt the twin SUs (HS2) fitted to my Bond Equipe GT4s (Spitfire Mk1 engine), using SU parts.  The car starts very easily, runs well - if a bit rich but, after around a minute, fuel gushes from the float chamber vent and main jet on the front carburettor (and now the rear one).  All the settings/adjustments are as specified and everything is scrupulously clean.  Thinking that perhaps the fuel pump was not of the correct type, I have replaced it with a new pump - but to no avail.  Everything seems to me to point to excessive fuel pressure.  However, before I buy and fit a fuel pressure regulator (which seems a bit unorthodox?), can anyone suggest anything else worth checking?  I believe I have eliminated all the usual potential causes, having spent countless hours over quite a few weeks trying just about everything . . .   

Link to comment
Share on other sites

the main cause for overfilling the chambers is floating debris in the feed lines, especially if its been disturbed, slivers of rubber get cut from the inside of the fuel hose as you insert the bundy tubes these bob back and forth in the feed line,  and generally lodge in the back of the float needle body,

 

do you have the latest needles with a viton tip ??   set the floats to the height   3/16"    but most are fixed, unless you washer under the valve face.

 

is the engine stable at idle no hard misfire /shaking which can upset the floats  ??

 

make sure the air filters  and gaskets are not covering any of the  carb. front face ports .

 

when  idling  take off the fuel hose to the carbs and run fuel in a jar. for a few seconds  ..you may see the culprit appear.

 

but have a serious look at the back of the needle body inside the top cover.

 

Pete

Link to comment
Share on other sites

Many thanks Darren, Pete and Steve for taking the time and trouble to help me in my hour of need!  I think I might have cracked it - the problem not the carburretor. Perhaps I missed the obvious - both float chambers had, over time, rotated and were sitting at a slight angle.  Having now restored them to the upright position, hey presto, no flooding!  I take it some movement of the float chamber is a design feature -  having checked the float chamber fixing bolt is tight, without eliminating movement from the vertical?  Thanks again all.  Rgds, Bob

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...