Jump to content

Oil drips


Jeffds1360
 Share

Recommended Posts

Nice pattern forming !

Put some cardboard down and parked over it 6x in the last week. Just a few inches each way each time

One is from gearbox drainplug.  I can fix that.

The other seems to be from the bellhousing lowest point. Bit worried that might be a bit of bother to repair. Which bearing do you lot think it may be? ...and how big a job is it? I thought I had sorted everything  :( cheers. 

20210304_120706.jpg

Link to comment
Share on other sites

Main oil seal. Likely that somebody has tightened the sump screws too much and distorted the centring of the oil seal. 
Either that or the oil seal has gone. Either way - it’s a gearbox out job to fix. I did mine the other Christmas. Lots of fun.  :)

Link to comment
Share on other sites

realistically the bellhousing is a low point and it could come from anywhere, rockers/head gasket/sump/rear oil seal. That is to be honest a pretty minor leak, as a tiny amount over time builds up. After 36 years of Triumph ownership I would say that, that leak is nothing to worry about and every time you fix one another will appear.

Link to comment
Share on other sites

Cheers all. I will not worry too much then. I do not seem to have any oil leaking externally anywhere.  I'll do a clean and trace with talc.

I've done 270 miles in 5 months since I sorted the half shaft and not been anywhere! Used 15 gallon as well but it has spent quite a few hours ticking over on the drive or in the garage (to her disgust) :)

Link to comment
Share on other sites

You’ve all made me feel much better after reading this thread. The much used Arthur Daly phrase “they all do that, sir” must somewhere have roots in a Triumph.

Earlier this week I pushed my car out of the garage, first time in several months. My catch tray (more correctly cat litter tray) was pretty dry. I assumed that meant that the sump was dry.

I spent a lot of time over last summer trying to track down an engine oil leak. It leaks after use but stops after the car had stood for a while. It drips from the bell housing. I’m fearful that it’s the rear oil seal. 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...