Jump to content

Intermittent brake failure


alan gower
 Share

Recommended Posts

I have a brake issue with my Spitfire which I cannot seem to resolve and would appreciate your comments. It started with a seized left front brake caliper several months ago and  probably through lack of use.  I stripped and found corrosion in the caliper cylinder and so eventually bought a pair of reconditioned calipers via TSSC from TD Fitchett. After fitting both, one caliper leaked brake fluid and Fitchett replaced this with another. They seem OK now. No sign of leaks. At the same time I replaced both flexible hoses from Rimmer. They seem OK. I also stripped the 5/8th brake master cylinder and bought a repair kit from Moss which I fitted. (I broke my golden rule of only replacing one thing at a time!). Having bled the brakes, furthest to nearest the master cylinder using a Haeger 1 man bleed kit which I have used successfully in the past the brake pedal felt OK and also with repeated pressing. So now driving the car the problem appears. Occasionally, about 1 in 5 to 10 times the brake pedal goes to the floor. Releasing and repressing the pedal it feels OK again only to repeat the fault after a number of pressings of the brake pedal.  I am only driving slowly around our estate for obvious reasons. The fluid level in the master cylinder does not seem to be going down. There is no external sign of brake fluid leak from the pipework or the front or rear brakes but I have not yet removed the rear drums to examine the rear brakes.

Link to comment
Share on other sites

Tony, Hi. I broke my golden rule of only replacing one part at a time, hence my pickle. I rashly threw away the old MC seals some while ago. I intend to buy a new OE MC but Rimmer are out and expecting stock in a week or so. I should add that the car has been used earlier this year before this problem. I guess water in the brake fluid led to the caliper seizing. I have another old car which had been distracting my attention and led to a period of lack of use.

Link to comment
Share on other sites

Its almost certainly going to be the little seal on the end of the piston that closes off the inlet from the reservoir when you start to press on the pedal. If it doesnt seat properly the fluid is pushed back into the reservoir instead of out to the brakes. It could be a damaged or poor quality seal or corrosion to the m/c sealing face and is probably repairable but would you have confidence in it....

Link to comment
Share on other sites

Johnny. Thanks for your comment, it makes sense. It rather feels like looking for a needle in a haystack at the moment. I have tried but failed to find a proper explanation of how a hydraulic braking system actually works, especially the MC on the interweb. I hope to replace the MC soon.

Link to comment
Share on other sites

It might be best not to know😂 When you realise the tiny seal that you must have replaced using the kit is all thats between you and no brakes its rather sobering. If it fails to seal while driving all you can do, as youve found, is keep on stamping on the pedal and hope that the hydraulic pressure generated will push the seal harder against the orifice and allow the brakes to work before you hit something...

People worry about the suspension collapsing or axles breaking on our cars but perhaps the first safety upgrade should be fitting dual circuit brakes👍

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...