Jump to content

Bad starting from cold


poppyman
 Share

Recommended Posts

Hi chaps, i have a problem on a GT6 mk3 that is reluctant to start from cold!  Once started its ok for the rest of the day, even if left for  6or7 hrs. It's fitted with elec/ign, new plugs coil ballast resistor cap rotor and fuel pump....... It starts 1st time on easy start sprayed in carbs..... even priming the pump does not help..... Help... what am i missing???  Thanks.

Tony.

 

Link to comment
Share on other sites

it sounds like the choke mechanism isnt working or is poorly adjusted. On my MK1 Vitesse you can take off the airfilter box, operate the choke and see each carb piston being lifted but your carbs might have a different set up with possibly an automatic temperature controlled choke.....

Link to comment
Share on other sites

41 minutes ago, Pete Lewis said:

i take it this is  CDS even a E , single starting valve on the front caarb with tubed enrichment to the rear carb ???

with or without temeperature compensators, ??     what breather system is fitted ?

pete

Hi Pete, 150CDSE  with temp compensators.

Tony.

Link to comment
Share on other sites

Make sure the litte sods are well closed when cold and closed at normal  should only open when too hot 

They bleed air past the butterfly if open and  your mixture is never correct, 

Do check the choke discs have clear metering holes .

If the mixture is correct the delrin washer on the head of the needle should be level with the base of the air piston

What air filters are you using ,  std or pancakes ??

Pete

 

Link to comment
Share on other sites

Hi Pete, this is on a mates car, so i am going to check it tomorrow. I am not well up on the strombergs  as it has been a long time, but thanks to you guys it's coming back to me now :)  I will of course come back and let you know what happens as my mate thinks it's electrical? but my money is on the carb's.

Tony.

Link to comment
Share on other sites

Also whip the top off see if the diaphragm is  correctly located in its position  dimples and has no splits when  stretched.

If its Wrinkled  wash in petrol it reverts to new size.

The choke is just a disc with metering small holes in , can get blocked with corrosion  just undo the screws to examine 

Pete

 

Link to comment
Share on other sites

Hi All, a big thank you for your help , pleased to say GT6 now starts first time :)  We could not see for sure if the holes were blocked? but went around with a pin and blew them out and got a face full of sh*t..... While we were at it we slowed the choke tickover speed down as it was reving very high..... So my pal also sends his thanks as well :)   I also know a bit more about that type of stromberg now.

Tony.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...